* Set maintainer to Debian QA Group <packages@qa.debian.org>. debian/4.3.9-3
authorJoey Schulze <joey@infodrom.org>
Wed, 14 May 2008 08:59:33 +0000 (08:59 +0000)
committerJoey Schulze <joey@infodrom.org>
Wed, 14 May 2008 08:59:33 +0000 (08:59 +0000)
* apache2 module depends now on apache2.2-common.

USAGE
debian/changelog
debian/control
debian/patches/001-usage.dpatch [new file with mode: 0644]
debian/patches/002-mysql_define.dpatch [new file with mode: 0644]
debian/patches/003-ftbfs_apache2.2.dpatch [new file with mode: 0644]
debian/patches/00list [new file with mode: 0644]
debian/rules
mod_auth_mysql.c

diff --git a/USAGE b/USAGE
index c891555..d83db0a 100644 (file)
--- a/USAGE
+++ b/USAGE
@@ -18,10 +18,7 @@ create table mysql_auth (
        primary key (username)
 );
 
-This would work quite well.  Remember that the passwd field needs to be long
-enough to store the entire password string -- for example, if you are using
-MD5 passwords, passwd needs to be 32 characters long, and if you are using
-SHA1 it must be 40 characters long.
+This would work quite well.
 
 NOTE 1: You don't have to use a new table for the purpose of storing
 usernames and passwords; I quite happily use a 'members' table (with all
index 61e4417..bddf1e8 100644 (file)
@@ -1,3 +1,18 @@
+libapache-mod-auth-mysql (4.3.9-3) unstable; urgency=medium
+
+  * QA Upload
+  * Set maintainer to Debian QA Group <packages@qa.debian.org>.
+  * apache2 module depends now on apache2.2-common.
+  * Removed the ,,changes* directories from the diff.gz.
+  * Use now make distclean instead of make clean in debian/rules.
+  * Build-depend now on dpatch.
+  * Build-depend now on debhelper 5 instead of 4.
+  * Converted the patches to dpatch.
+  * Applied a patch to fix FTBFS against apache2.2 (Closes: #389579).
+    Thanks to Julian Calaby for the patch.
+
+ -- Mario Iseli <admin@marioiseli.com>  Sun, 11 Feb 2007 14:04:10 +0100
+
 libapache-mod-auth-mysql (4.3.9-2.1) unstable; urgency=medium
 
   * Non-maintainer upload.
@@ -14,7 +29,7 @@ libapache-mod-auth-mysql (4.3.9-2) unstable; urgency=low
 
 libapache-mod-auth-mysql (4.3.9-1) unstable; urgency=low
 
-  * New upstream release, which codifies the way that multiple require
+sqq!q1  * New upstream release, which codifies the way that multiple require
     statements are meant to work.
 
  -- Matthew Palmer <mpalmer@debian.org>  Fri, 24 Dec 2004 00:30:40 +1100
index 4770cf1..3bb2b60 100644 (file)
@@ -1,9 +1,9 @@
 Source: libapache-mod-auth-mysql
 Section: web
 Priority: optional
-Maintainer: Matthew Palmer <mpalmer@debian.org>
+Maintainer: Debian QA Group <packages@qa.debian.org>
 Standards-Version: 3.6.1
-Build-Depends: debhelper (>= 4), apache-dev, libmysqlclient15-dev, apache2-threaded-dev (>= 2.0.50-10)
+Build-Depends: debhelper (>= 5.0.0), dpatch, apache-dev, libmysqlclient15-dev, apache2-threaded-dev (>= 2.0.50-10)
 
 Package: libapache-mod-auth-mysql
 Architecture: any
@@ -18,7 +18,7 @@ Description: Apache module for MySQL authentication
 
 Package: libapache2-mod-auth-mysql
 Architecture: any
-Depends: ${shlibs:Depends}, apache2-common (>= 2.0.50-10)
+Depends: ${shlibs:Depends}, apache2.2-common (>= 2.2.3-3)
 Description: Apache 2 module for MySQL authentication
  A module for the Apache 2 web server which enables HTTP authentication
  against information stored in a MySQL database.
diff --git a/debian/patches/001-usage.dpatch b/debian/patches/001-usage.dpatch
new file mode 100644 (file)
index 0000000..8d66cb5
--- /dev/null
@@ -0,0 +1,21 @@
+#! /bin/sh /usr/share/dpatch/dpatch-run
+## 001-usage.dpatch by Matthew Palmer <mpalmer@debian.org>
+##
+## DP: Explain the md5 and sha1 cryptographic methods better
+
+@DPATCH@
+
+--- orig/USAGE
++++ mod/USAGE
+@@ -18,7 +18,10 @@
+       primary key (username)
+ );
+-This would work quite well.
++This would work quite well.  Remember that the passwd field needs to be long
++enough to store the entire password string -- for example, if you are using
++MD5 passwords, passwd needs to be 32 characters long, and if you are using
++SHA1 it must be 40 characters long.
+ NOTE 1: You don't have to use a new table for the purpose of storing
+ usernames and passwords; I quite happily use a 'members' table (with all
diff --git a/debian/patches/002-mysql_define.dpatch b/debian/patches/002-mysql_define.dpatch
new file mode 100644 (file)
index 0000000..aa6bba5
--- /dev/null
@@ -0,0 +1,18 @@
+#! /bin/sh /usr/share/dpatch/dpatch-run
+## 002-mysql_define.dpatch by Matthew Palmer <mpalmer@debian.org>
+##
+## DP: Sets the constant AUTH_MYSQL_VERSION to the correct version
+
+@DPATCH@
+
+--- orig/mod_auth_mysql.c
++++ mod/mod_auth_mysql.c
+@@ -21,7 +21,7 @@
+  * SHA1 hash support
+  */
+-#define AUTH_MYSQL_VERSION "4.3.9"
++#define AUTH_MYSQL_VERSION "4.3.9-1"
+ #include "config.h"
diff --git a/debian/patches/003-ftbfs_apache2.2.dpatch b/debian/patches/003-ftbfs_apache2.2.dpatch
new file mode 100644 (file)
index 0000000..0864569
--- /dev/null
@@ -0,0 +1,180 @@
+#! /bin/sh /usr/share/dpatch/dpatch-run
+## 003-ftbfs_apache2.2.dpatch by Julian Calaby <julian.calaby@gmail.com>
+##
+## DP: Fixes the FTBFS against apache2.2 (see #389579 for more information)
+
+@DPATCH@
+
+--- libapache-mod-auth-mysql-4.3.9.old/mod_auth_mysql.c        2006-11-21 15:07:43.000000000 +1100
++++ libapache-mod-auth-mysql-4.3.9/mod_auth_mysql.c    2006-11-21 16:42:29.000000000 +1100
+@@ -48,6 +48,7 @@
+ #include <http_log.h>
+ #ifdef APACHE2
+ #include "http_request.h"   /* for ap_hook_(check_user_id | auth_checker)*/
++#include <apr_general.h>
+ #include <apr_md5.h>
+ #include <apr_sha1.h>
+ #else
+@@ -684,123 +685,123 @@
+                 RSRC_CONF,    "default database for MySQL authentication" ),
+    AP_INIT_TAKE1( "AuthMySQL_Host",   ap_set_string_slot,
+-                (void*)APR_XtOffsetOf(mysql_auth_config_rec, db_host),
++                (void*)APR_OFFSETOF(mysql_auth_config_rec, db_host),
+                 OR_AUTHCFG,   "database host" ),
+    AP_INIT_TAKE1( "Auth_MySQL_Host",  ap_set_string_slot,
+-                (void*)APR_XtOffsetOf(mysql_auth_config_rec, db_host),
++                (void*)APR_OFFSETOF(mysql_auth_config_rec, db_host),
+                 OR_AUTHCFG,   "database host" ),
+    AP_INIT_TAKE1( "Auth_MySQL_Socket",        ap_set_string_slot,
+-                (void*)APR_XtOffsetOf(mysql_auth_config_rec, db_socket),
++                (void*)APR_OFFSETOF(mysql_auth_config_rec, db_socket),
+                 OR_AUTHCFG,   "database host socket" ),
+    AP_INIT_TAKE1( "AuthMySQL_Socket", ap_set_string_slot,
+-                (void*)APR_XtOffsetOf(mysql_auth_config_rec, db_socket),
++                (void*)APR_OFFSETOF(mysql_auth_config_rec, db_socket),
+                 OR_AUTHCFG,   "database host socket" ),
+    AP_INIT_TAKE1( "Auth_MySQL_Port",  ap_set_string_slot,
+-                (void*)APR_XtOffsetOf(mysql_auth_config_rec, db_port),
++                (void*)APR_OFFSETOF(mysql_auth_config_rec, db_port),
+                 OR_AUTHCFG,   "database host port" ),
+    AP_INIT_TAKE1( "AuthMySQL_Port",   ap_set_string_slot,
+-                (void*)APR_XtOffsetOf(mysql_auth_config_rec, db_port),
++                (void*)APR_OFFSETOF(mysql_auth_config_rec, db_port),
+                 OR_AUTHCFG,   "database host port" ),
+    AP_INIT_TAKE1( "Auth_MySQL_Username",      ap_set_string_slot,
+-                (void*)APR_XtOffsetOf(mysql_auth_config_rec, db_user),
++                (void*)APR_OFFSETOF(mysql_auth_config_rec, db_user),
+                 OR_AUTHCFG,   "database user" ),
+    AP_INIT_TAKE1( "AuthMySQL_User",   ap_set_string_slot,
+-                (void*)APR_XtOffsetOf(mysql_auth_config_rec, db_user),
++                (void*)APR_OFFSETOF(mysql_auth_config_rec, db_user),
+                 OR_AUTHCFG,   "database user" ),
+    AP_INIT_TAKE1( "Auth_MySQL_Password",      ap_set_string_slot,
+-              (void*)APR_XtOffsetOf(mysql_auth_config_rec, db_pwd),
++              (void*)APR_OFFSETOF(mysql_auth_config_rec, db_pwd),
+                 OR_AUTHCFG,   "database password" ),
+    AP_INIT_TAKE1( "AuthMySQL_Password",                       ap_set_string_slot,
+-                (void*)APR_XtOffsetOf(mysql_auth_config_rec, db_pwd),
++                (void*)APR_OFFSETOF(mysql_auth_config_rec, db_pwd),
+                 OR_AUTHCFG,   "database password" ),
+    AP_INIT_TAKE1( "Auth_MySQL_DB",            ap_set_string_slot,
+-                (void*)APR_XtOffsetOf(mysql_auth_config_rec, db_name),
++                (void*)APR_OFFSETOF(mysql_auth_config_rec, db_name),
+                 OR_AUTHCFG,   "database name" ),
+    AP_INIT_TAKE1( "AuthMySQL_DB",     ap_set_string_slot,
+-                (void*)APR_XtOffsetOf(mysql_auth_config_rec, db_name),
++                (void*)APR_OFFSETOF(mysql_auth_config_rec, db_name),
+                 OR_AUTHCFG,   "database name" ),
+    AP_INIT_TAKE1( "Auth_MySQL_Password_Table",                ap_set_string_slot,
+-                (void*)APR_XtOffsetOf(mysql_auth_config_rec, user_table),
++                (void*)APR_OFFSETOF(mysql_auth_config_rec, user_table),
+                 OR_AUTHCFG,   "Name of the MySQL table containing the password/user-name combination" ),
+    AP_INIT_TAKE1( "AuthMySQL_Password_Table",         ap_set_string_slot,
+-                (void*)APR_XtOffsetOf(mysql_auth_config_rec, user_table),
++                (void*)APR_OFFSETOF(mysql_auth_config_rec, user_table),
+                 OR_AUTHCFG,   "Name of the MySQL table containing the password/user-name combination" ),
+    AP_INIT_TAKE1( "Auth_MySQL_Group_Table",           ap_set_string_slot,
+-                (void*)APR_XtOffsetOf(mysql_auth_config_rec, group_table),
++                (void*)APR_OFFSETOF(mysql_auth_config_rec, group_table),
+                 OR_AUTHCFG,   "Name of the MySQL table containing the group-name/user-name combination; can be the same as the password-table." ),
+    AP_INIT_TAKE1( "Auth_MySQL_Group_Clause",          ap_set_string_slot,
+-                (void*)APR_XtOffsetOf(mysql_auth_config_rec, group_where_clause),
++                (void*)APR_OFFSETOF(mysql_auth_config_rec, group_where_clause),
+                 OR_AUTHCFG,   "Additional WHERE clause for group/user-name lookup" ),
+    AP_INIT_TAKE1( "AuthMySQL_Group_Table",            ap_set_string_slot,
+-                (void*)APR_XtOffsetOf(mysql_auth_config_rec, group_table),
++                (void*)APR_OFFSETOF(mysql_auth_config_rec, group_table),
+                 OR_AUTHCFG,   "Name of the MySQL table containing the group-name/user-name combination; can be the same as the password-table." ),
+    AP_INIT_TAKE1( "Auth_MySQL_Password_Field",                ap_set_string_slot,
+-                (void*)APR_XtOffsetOf(mysql_auth_config_rec, password_field),
++                (void*)APR_OFFSETOF(mysql_auth_config_rec, password_field),
+                 OR_AUTHCFG,   "The name of the field in the MySQL password table" ),
+    AP_INIT_TAKE1( "AuthMySQL_Password_Field",         ap_set_string_slot,
+-                (void*)APR_XtOffsetOf(mysql_auth_config_rec, password_field),
++                (void*)APR_OFFSETOF(mysql_auth_config_rec, password_field),
+                 OR_AUTHCFG,   "The name of the field in the MySQL password table" ),
+    AP_INIT_TAKE1( "Auth_MySQL_Password_Clause",               ap_set_string_slot,
+-                (void*)APR_XtOffsetOf(mysql_auth_config_rec, password_where_clause),
++                (void*)APR_OFFSETOF(mysql_auth_config_rec, password_where_clause),
+                 OR_AUTHCFG,   "Additional WHERE clause for group password/user-name lookup" ),
+    AP_INIT_TAKE1( "Auth_MySQL_Username_Field",                ap_set_string_slot,
+-                (void*)APR_XtOffsetOf(mysql_auth_config_rec, user_field),
++                (void*)APR_OFFSETOF(mysql_auth_config_rec, user_field),
+                 OR_AUTHCFG,   "The name of the user-name field in the MySQL password (and possibly group) table(s)." ),
+    AP_INIT_TAKE1( "AuthMySQL_Username_Field",         ap_set_string_slot,
+-                (void*)APR_XtOffsetOf(mysql_auth_config_rec, user_field),
++                (void*)APR_OFFSETOF(mysql_auth_config_rec, user_field),
+                 OR_AUTHCFG,   "The name of the user-name field in the MySQL password (and possibly group) table(s)." ),
+    AP_INIT_TAKE1( "Auth_MySQL_Group_Field",           ap_set_string_slot,
+-                (void*)APR_XtOffsetOf(mysql_auth_config_rec, group_field),
++                (void*)APR_OFFSETOF(mysql_auth_config_rec, group_field),
+                 OR_AUTHCFG,   "The name of the group field in the MySQL group table; must be set if you want to use groups." ),
+    AP_INIT_TAKE1( "AuthMySQL_Group_Field",            ap_set_string_slot,
+-                (void*)APR_XtOffsetOf(mysql_auth_config_rec, group_field),
++                (void*)APR_OFFSETOF(mysql_auth_config_rec, group_field),
+                 OR_AUTHCFG,   "The name of the group field in the MySQL group table; must be set if you want to use groups." ),
+    AP_INIT_TAKE1( "Auth_MySQL_Group_User_Field",      ap_set_string_slot,
+-                (void*)APR_XtOffsetOf(mysql_auth_config_rec, group_user_field),
++                (void*)APR_OFFSETOF(mysql_auth_config_rec, group_user_field),
+                 OR_AUTHCFG,   "The name of the user-name field in the MySQL group table; defaults to the same as the username field for the password table." ),
+    AP_INIT_TAKE1( "AuthMySQL_Group_User_Field",               ap_set_string_slot,
+-                (void*)APR_XtOffsetOf(mysql_auth_config_rec, group_user_field),
++                (void*)APR_OFFSETOF(mysql_auth_config_rec, group_user_field),
+                 OR_AUTHCFG,   "The name of the user-name field in the MySQL group table; defaults to the same as the username field for the password table." ),
+    AP_INIT_FLAG( "Auth_MySQL_Empty_Passwords",                ap_set_flag_slot,
+-               (void*)APR_XtOffsetOf(mysql_auth_config_rec, allow_empty_passwords),
++               (void*)APR_OFFSETOF(mysql_auth_config_rec, allow_empty_passwords),
+                OR_AUTHCFG,    "Enable (on) or disable (off) empty password strings; in which case any user password is accepted." ),
+    AP_INIT_FLAG( "AuthMySQL_Empty_Passwords",         ap_set_flag_slot,
+-               (void*)APR_XtOffsetOf(mysql_auth_config_rec, allow_empty_passwords),
++               (void*)APR_OFFSETOF(mysql_auth_config_rec, allow_empty_passwords),
+                OR_AUTHCFG,    "Enable (on) or disable (off) empty password strings; in which case any user password is accepted." ),
+    AP_INIT_FLAG( "Auth_MySQL_Authoritative",          ap_set_flag_slot,
+-               (void*)APR_XtOffsetOf(mysql_auth_config_rec, authoritative),
++               (void*)APR_OFFSETOF(mysql_auth_config_rec, authoritative),
+                OR_AUTHCFG,    "When 'on' the MySQL database is taken to be authoritative and access control is not passed along to other db or access modules." ),
+    AP_INIT_FLAG( "AuthMySQL_Authoritative",           ap_set_flag_slot,
+-               (void*)APR_XtOffsetOf(mysql_auth_config_rec, authoritative),
++               (void*)APR_OFFSETOF(mysql_auth_config_rec, authoritative),
+                OR_AUTHCFG,    "When 'on' the MySQL database is taken to be authoritative and access control is not passed along to other db or access modules." ),
+    AP_INIT_FLAG( "AuthMySQL_AllowOverride",           set_auth_mysql_override,
+@@ -848,7 +849,7 @@
+                OR_AUTHCFG,    "Enable MySQL authentication" ),
+    AP_INIT_TAKE1( "Auth_MySQL_Where",         ap_set_string_slot,
+-                (void*)APR_XtOffsetOf(mysql_auth_config_rec, password_where_clause),
++                (void*)APR_OFFSETOF(mysql_auth_config_rec, password_where_clause),
+                 OR_AUTHCFG,   "Additional WHERE clause for group password/user-name lookup" ),
+   { NULL }
diff --git a/debian/patches/00list b/debian/patches/00list
new file mode 100644 (file)
index 0000000..f56de16
--- /dev/null
@@ -0,0 +1,3 @@
+001-usage
+002-mysql_define
+003-ftbfs_apache2.2
index b66bbcf..246e026 100644 (file)
@@ -4,6 +4,7 @@ export DH_COMPAT=4
 APACHE13=$(CURDIR)/debian/libapache-mod-auth-mysql
 APACHE2=$(CURDIR)/debian/libapache2-mod-auth-mysql
 
+include /usr/share/dpatch/dpatch.make
 
 ifneq (,$(findstring debug,$(DEB_BUILD_OPTIONS)))
        CFLAGS += -g
@@ -12,18 +13,18 @@ ifeq (,$(findstring nostrip,$(DEB_BUILD_OPTIONS)))
         INSTALL_PROGRAM += -s
 endif
 
-configure: configure-stamp
+configure: patch configure-stamp
 configure-stamp:
        dh_testdir
        # Configuration commands
        ./configure --enable-apache2
        touch configure-stamp
 
-clean:
+clean: unpatch
        dh_testdir
        dh_testroot
        dh_clean -A
-       -make clean
+       -make distclean
        rm -f config.status config.log config.h
        rm -f configure-stamp build-stamp
 
index 78a0256..ee1f94b 100644 (file)
@@ -21,7 +21,7 @@
  * SHA1 hash support
  */
 
-#define AUTH_MYSQL_VERSION "4.3.9-2"
+#define AUTH_MYSQL_VERSION "4.3.9"
 
 #include "config.h"