Apply patch properly via dpatch
authorJoey Schulze <joey@infodrom.org>
Fri, 21 Nov 2008 15:29:20 +0000 (15:29 +0000)
committerJoey Schulze <joey@infodrom.org>
Fri, 21 Nov 2008 15:29:20 +0000 (15:29 +0000)
USAGE
debian/changelog
debian/patches/00list
debian/patches/011-auth_basic.dpatch [new file with mode: 0755]

diff --git a/USAGE b/USAGE
index 1d3087d..d83db0a 100644 (file)
--- a/USAGE
+++ b/USAGE
@@ -123,22 +123,3 @@ become plaintext equivalents.
 
 The full set of directives available are now listed in the file DIRECTIVES,
 for ease of perusal.
 
 The full set of directives available are now listed in the file DIRECTIVES,
 for ease of perusal.
-
-Disable other Auth methods
---------------------------
-
-For some reason Apache has problems handing over authority to this
-module if this is requested an another auth module is also loaded.
-
-If you have another authentication module loaded, you'll have to
-disable it the hard way.
-
-AuthBasicAuthoritative Off
-AuthUserFile /dev/null
-
-The following option is not sufficient
-
-Auth_MySQL_Authoritative On
-
-If you experience similar problems with group membership, try
-repeating the same procedure with AuthGroupFile.
index 8762f39..c4844a2 100644 (file)
@@ -1,7 +1,7 @@
 mod-auth-mysql (4.3.9-10) unstable; urgency=low
 
 mod-auth-mysql (4.3.9-10) unstable; urgency=low
 
-  * Document disabling BasicAuth in USAGE (closes: Bug#502895)
-  * Document disabling the group file in USAGE (closes: Bug#382242)
+  * Document disabling BasicAuth and basic group file in USAGE
+   [011-auth_basic.dpatch] (closes: Bug#502895, Bug#382242)
 
  --
 
 
  --
 
index ce27fbd..4e02325 100644 (file)
@@ -7,3 +7,4 @@
 008-make_scrambled_password
 009-port-int
 010-enctype-apache
 008-make_scrambled_password
 009-port-int
 010-enctype-apache
+011-auth_basic
diff --git a/debian/patches/011-auth_basic.dpatch b/debian/patches/011-auth_basic.dpatch
new file mode 100755 (executable)
index 0000000..dc03a9d
--- /dev/null
@@ -0,0 +1,32 @@
+#! /bin/sh /usr/share/dpatch/dpatch-run
+## 011-auth_basic.dpatch by Joey Schulze <joey@infodrom.org>
+##
+## DP: Document problems with other authentication modules
+
+@DPATCH@
+diff -urNad mod-auth-mysql~/USAGE mod-auth-mysql/USAGE
+--- mod-auth-mysql~/USAGE      2008-11-21 16:16:37.000000000 +0100
++++ mod-auth-mysql/USAGE       2008-11-21 16:24:41.000000000 +0100
+@@ -123,3 +123,22 @@
+ The full set of directives available are now listed in the file DIRECTIVES,
+ for ease of perusal.
++
++Disable other Auth methods
++--------------------------
++
++For some reason Apache has problems handing over authority to this
++module if this is requested an another auth module is also loaded.
++
++If you have another authentication module loaded, you'll have to
++disable it the hard way.
++
++AuthBasicAuthoritative Off
++AuthUserFile /dev/null
++
++The following option is not sufficient
++
++Auth_MySQL_Authoritative On
++
++If you experience similar problems with group membership, try
++repeating the same procedure with AuthGroupFile.