Patches are handled by dpatch
authorJoey Schulze <joey@infodrom.org>
Wed, 14 May 2008 15:00:28 +0000 (15:00 +0000)
committerJoey Schulze <joey@infodrom.org>
Wed, 14 May 2008 15:00:28 +0000 (15:00 +0000)
debian/changelog
debian/patches/005-directives.dpatch [new file with mode: 0644]
debian/patches/00list

index 10318d3..84aedfd 100644 (file)
@@ -3,6 +3,7 @@ mod-auth-mysql (4.3.9-8) unstable; urgency=low
   * New maintainer
   * New source package name
   * Clarified history and license
+  * Improve documentation wrt. Auth_MySQL_Group_Field
 
  --
 
diff --git a/debian/patches/005-directives.dpatch b/debian/patches/005-directives.dpatch
new file mode 100644 (file)
index 0000000..8f9eeb3
--- /dev/null
@@ -0,0 +1,19 @@
+#! /bin/sh /usr/share/dpatch/dpatch-run
+## 005-directives.dpatch by Joey Schulze <joey@debian.org>
+##
+## All lines beginning with `## DP:' are a description of the patch.
+## DP: Improve documentation for Auth_MySQL_Group_Field
+
+diff -u -p -r1.1 -r1.2
+--- mod-auth-mysql/DIRECTIVES  14 May 2008 08:46:20 -0000      1.1
++++ mod-auth-mysql/DIRECTIVES  14 May 2008 12:53:34 -0000      1.2
+@@ -125,7 +125,8 @@ AuthMySQL_Password_Field <password_field
+       Synonym for Auth_MySQL_Password_Field.
+ Auth_MySQL_Group_Field <group_field_name>
+-      As per ...Username_Field above.  Defaults to 'groups'.
++      As per ...Username_Field above.  Defaults to 'groups'.  The query 
++      will use FIND_IN_SET(<group_name>,<group_field_name>).
+       
+ AuthMySQL_Group_Field <group_field_name>
+       Synonym for Auth_MySQL_Group_Field.
index 628f78c..175cdb7 100644 (file)
@@ -2,3 +2,4 @@
 002-mysql_define
 003-ftbfs_apache2.2
 004-reconnect
+005-directives.dpatch