Cleanup
authorJoey Schulze <joey@infodrom.org>
Wed, 14 May 2008 09:47:04 +0000 (09:47 +0000)
committerJoey Schulze <joey@infodrom.org>
Wed, 14 May 2008 09:47:04 +0000 (09:47 +0000)
debian/rules

index 50d1890..8398398 100644 (file)
@@ -1,5 +1,22 @@
 #!/usr/bin/make -f
 
+#   Copyright 2002-2005   Matthew Palmer <mpalmer@debian.org>
+#   Copyright 2008   Joey Schulze <joey@@infodrom.org>
+#
+#   This program is free software; you can redistribute it and/or modify
+#   it under the terms of the GNU General Public License as published by
+#   the Free Software Foundation; version 2 dated June, 1991.
+#
+#   This program is distributed in the hope that it will be useful,
+#   but WITHOUT ANY WARRANTY; without even the implied warranty of
+#   MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+#   GNU General Public License for more details.
+#
+#   You should have received a copy of the GNU General Public License
+#   along with this program;  if not, write to the Free Software
+#   Foundation Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307, USA
+
+
 APACHE2=$(CURDIR)/debian/libapache2-mod-auth-mysql
 
 include /usr/share/dpatch/dpatch.make
@@ -7,7 +24,6 @@ include /usr/share/dpatch/dpatch.make
 configure: patch configure-stamp
 configure-stamp:
        dh_testdir
-       # Configuration commands
        ./configure --disable-apache13 --enable-apache2
        touch configure-stamp
 
@@ -15,7 +31,7 @@ clean: unpatch
        dh_testdir
        dh_testroot
        dh_clean -A
-       [ ! -f Makefile ] || $(MAKE) distclean
+       test ! -f Makefile || $(MAKE) distclean
        rm -f config.status config.log config.h
        rm -f configure-stamp build-stamp