Let dh_strip handle DEB_BUILD_OPTIONS=nostrip.
authorJoey Schulze <joey@infodrom.org>
Wed, 14 May 2008 09:04:43 +0000 (09:04 +0000)
committerJoey Schulze <joey@infodrom.org>
Wed, 14 May 2008 09:04:43 +0000 (09:04 +0000)
Remove support for DEB_BUILD_OPTIONS=debug.
Don't ignore errors from `make distclean'.

debian/rules

index 1b4267d..81e3725 100644 (file)
@@ -4,13 +4,6 @@ APACHE2=$(CURDIR)/debian/libapache2-mod-auth-mysql
 
 include /usr/share/dpatch/dpatch.make
 
-ifneq (,$(findstring debug,$(DEB_BUILD_OPTIONS)))
-       CFLAGS += -g
-endif
-ifeq (,$(findstring nostrip,$(DEB_BUILD_OPTIONS)))
-        INSTALL_PROGRAM += -s
-endif
-
 configure: patch configure-stamp
 configure-stamp:
        dh_testdir
@@ -22,7 +15,7 @@ clean: unpatch
        dh_testdir
        dh_testroot
        dh_clean -A
-       -make distclean
+       $(MAKE) distclean
        rm -f config.status config.log config.h
        rm -f configure-stamp build-stamp
 
@@ -39,7 +32,7 @@ install: build
        dh_testroot
        dh_installdirs -A
 
-       install -s -m 644 apache2_mod_auth_mysql.so $(APACHE2)/usr/lib/apache2/modules/mod_auth_mysql.so
+       install -m 644 apache2_mod_auth_mysql.so $(APACHE2)/usr/lib/apache2/modules/mod_auth_mysql.so
        install -m 644 auth_mysql.load $(APACHE2)/etc/apache2/mods-available
 
 binary: binary-arch binary-indep
@@ -49,6 +42,7 @@ binary-arch: install
        dh_testroot
        dh_installdocs -A
        dh_installchangelogs -A
+       dh_strip -A
        dh_compress -A
        dh_installdeb -A
        dh_shlibdeps -A