Incorporate 2.2.0 patches master
authorJoey Schulze <joey@infodrom.org>
Mon, 1 May 2017 20:26:16 +0000 (22:26 +0200)
committerJoey Schulze <joey@infodrom.org>
Mon, 1 May 2017 20:32:42 +0000 (22:32 +0200)
debian/patches/0001-Import-Debian-patches-from-2.2.0.patch [new file with mode: 0644]
debian/patches/series [new file with mode: 0644]

diff --git a/debian/patches/0001-Import-Debian-patches-from-2.2.0.patch b/debian/patches/0001-Import-Debian-patches-from-2.2.0.patch
new file mode 100644 (file)
index 0000000..fda9e4a
--- /dev/null
@@ -0,0 +1,287 @@
+From: Joey Schulze <joey@infodrom.org>
+Date: Mon, 1 May 2017 21:15:08 +0200
+Subject: Import Debian patches from 2.2.0
+
+---
+ Makefile.in      | 14 +++++---------
+ configure.in     |  6 +++++-
+ contrib/Makefile |  2 ++
+ docs/Makefile.in |  3 ++-
+ docs/hmrc.4      | 12 +++++++-----
+ docs/hypermail.1 | 12 ++++++++----
+ src/Makefile.in  | 13 +++++--------
+ src/trio.c       |  7 +++++++
+ 8 files changed, 41 insertions(+), 28 deletions(-)
+ create mode 100644 contrib/Makefile
+
+diff --git a/Makefile.in b/Makefile.in
+index 0846968..5475254 100644
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -28,9 +28,9 @@ INSTALL_PROG=@INSTALL@
+  
+ # Compiler to use
+ CC=@CC@ 
+-CFLAGS=@CFLAGS@ @INCLUDES@ -Ipcre -DTRIO_MINIMAL $(WARNINGS)
++CFLAGS=@CFLAGS@ @INCLUDES@ -DTRIO_MINIMAL $(WARNINGS)
+ LIBS=@LIBS@
+-LDFLAGS=@LDFLAGS@ -Lpcre
++LDFLAGS=@LDFLAGS@
+ all:   hypermail support 
+@@ -40,29 +40,25 @@ hypermail:
+               cgidir="$(cgidir)" bindir="$(bindir)" LIBS="$(LIBS)"
+ support:   
+-      @cd archive; $(MAKE) all CC="$(CC)" CFLAGS="$(CFLAGS)" 
+ install: 
+       @cd src; $(MAKE) install CC="$(CC)" CFLAGS="$(CFLAGS)" \
+               cgidir="$(cgidir)" bindir="$(bindir)" LIBS="$(LIBS)"
+       @cd docs; $(MAKE) install CC="$(CC)" CFLAGS="$(CFLAGS)" \
+               $(MAKEFLAGS) mandir="$(mandir)" htmldir="$(htmldir)"
+-      @cd archive; $(MAKE) install CC="$(CC)" CFLAGS="$(CFLAGS)" \
+-              bindir="$(bindir)"
++      @cd contrib; $(MAKE) install bindir="$(bindir)"
+ uninstall: 
+       @cd src; $(MAKE) uninstall cgidir="$(cgidir)" bindir="$(bindir)" 
+       @cd docs; $(MAKE) uninstall mandir="$(mandir)" htmldir="$(htmldir)"
+-      @cd archive; $(MAKE) uninstall bindir="$(bindir)"
+ lint: 
+       @cd src; $(MAKE) lint 
+-      @cd archive; $(MAKE) lint 
+ clean:
+       @cd src; $(MAKE) clean 
+       @cd docs; $(MAKE) clean 
+-      @cd archive; $(MAKE) clean 
++      @cd libcgi; $(MAKE) clean 
+       rm -f lint.out
+ clobber: clean
+@@ -70,7 +66,6 @@ clobber: clean
+       rm -f config.cache
+       rm -f config.log
+       rm -f config.status
+-      rm -f archive/Makefile
+       rm -f docs/Makefile
+       rm -f libcgi/Makefile
+       rm -f src/Makefile
+@@ -79,6 +74,7 @@ clobber: clean
+       rm -rf tests/testdir
+       rm -rf tests/mail-archive
+       rm -f Makefile
++      rm -f libcgi/Makefile
+ distclean: clobber
+       rm -f tests/testmail
+diff --git a/configure.in b/configure.in
+index d1b1ffb..f5fd9f5 100644
+--- a/configure.in
++++ b/configure.in
+@@ -11,7 +11,7 @@ INCLUDES=""
+ GDBM_INCLUDE=""
+ GDBM_LIB=""
+ FNV_DEP=""
+-SUBDIRS="src/pcre"
++dnl SUBDIRS="src/pcre"
+ dnl ===========================================================================
+ dnl Get host, target and build variables filled with appropriate info.
+@@ -69,6 +69,10 @@ case "$host" in
+       CFLAGS="$CFLAGS -Ae"
+     fi
+     ;;
++  alpha*-*-linux*)
++    # alpha flags
++    CFLAGS="$CFLAGS -mieee"
++    ;;
+   *-dec-osf*)
+     # DEC OSF flags 
+     CFLAGS="$CFLAGS -mieee"
+diff --git a/contrib/Makefile b/contrib/Makefile
+new file mode 100644
+index 0000000..d5509e4
+--- /dev/null
++++ b/contrib/Makefile
+@@ -0,0 +1,2 @@
++install:
++      install -m 0755 hypetombox.pl msg2hypermailarchive.py $(bindir)
+diff --git a/docs/Makefile.in b/docs/Makefile.in
+index cfc36a7..df75995 100644
+--- a/docs/Makefile.in
++++ b/docs/Makefile.in
+@@ -31,7 +31,7 @@ uninstall:
+               rmdir $(htmldir); \
+       fi)
+-install: install.man install.html
++install: #We don't need it
+ install.man:
+       @(if [ ! -d $(mandir) ]; then mkdir -p $(mandir); fi)
+@@ -54,3 +54,4 @@ install.html:
+ clean:
+ clobber:
+ distclean:
++w:
+diff --git a/docs/hmrc.4 b/docs/hmrc.4
+index 6ada8b1..4c15d45 100644
+--- a/docs/hmrc.4
++++ b/docs/hmrc.4
+@@ -1,4 +1,4 @@
+-.TH hmrc 4 "February 04, 2004"
++.TH hmrc 5 "February 04, 2004"
+ .SH NAME
+ hmrc \- Hypermail configuration file 
+ .SH DESCRIPTION
+@@ -65,7 +65,7 @@ and generating archives.
+       ru (ru_RU) - Russian
+       sv (sv_SE) - Swedish
+-.nr
++.in
+ The directory /usr/share/i18n/locales on many systems has the locale
+ codes that are available on that system.
+@@ -877,7 +877,8 @@ files so appropriate information can be filled in at runtime.
+      %u - Expanded version link (HMURL,PROGNAME,VERSION)
+      \\n - newline character
+      \\t - tab character
+-.nr
++.ad
++.fi
+ .LP
+ .B Additional cookies generate the complete META lines: 
+ .LP
+@@ -885,5 +886,6 @@ files so appropriate information can be filled in at runtime.
+      %A - Author META TAG - Not valid on index pages
+      %D - Date META TAG - Not valid on index pages
+      %S - Subject META TAG 
+-.nr
+-.TP
++.ad
++.fi
++.P
+diff --git a/docs/hypermail.1 b/docs/hypermail.1
+index a1b3ef5..062e7f2 100644
+--- a/docs/hypermail.1
++++ b/docs/hypermail.1
+@@ -472,7 +472,8 @@ Define the list of headers to be displayed if the variable HM_SHOWHEADERS is set
+   show_headers = Subject 
+   show_headers = Date 
+   show_headers = Message-ID 
+-.nr
++.ad
++.fi
+ As a special case you can use the identifier ``*'' as header to tell
+ .B hypermail
+@@ -488,7 +489,8 @@ multiple lines or comma or space separated on a single line.
+   inline_types = image/gif image/jpeg 
+  or 
+   inline_types = image/gif inline_types = image/jpeg 
+-.nr
++.ad
++.fi
+ .TP
+ .B HM_IGNORE_TYPES indicate attachment types to ignore
+ This is the list of MIME attachment types that you do not want to do 
+@@ -500,7 +502,8 @@ on multiple lines or comma or space separated on a single line.
+  or 
+   ignore_types = text/x-vcard 
+   ignore_types = application/x-msdownload 
+-.nr
++.ad
++.fi
+ .TP
+ .B HM_LINKQUOTES boolean_number
+ Set this to On to create fine-grained links from quoted
+@@ -627,5 +630,6 @@ Moritz Willers <Moritz.Willers@ubsw.com>
+ David Bau <davidbau@hotmail.com>
+ Brian Kirkby <bkirkby@Concentrico.net>
+ William King <William.King@dadaboom.com>
+-.nr
++.ad
++.fi
+ .TP
+diff --git a/src/Makefile.in b/src/Makefile.in
+index 61b9904..9c81e3b 100644
+--- a/src/Makefile.in
++++ b/src/Makefile.in
+@@ -24,15 +24,15 @@ CC=@CC@
+ # Installation program to use
+ INSTALL_PROG=@INSTALL@ 
+-SPLINTFLAGS=-Ipcre 
++SPLINTFLAGS=
+  
+ #WNOERROR=-Werror
+ #WARNINGS=$(WNOERROR) -ansi -pedantic -Wall -Wtraditional -Wshadow -Wpointer-arith -Wcast-qual -Wcast-align -Waggregate-return -Wstrict-prototypes -Wmissing-prototypes -Wnested-externs -Winline -Dlint
+-CFLAGS=@CFLAGS@ @INCLUDES@ -Ipcre -DTRIO_MINIMAL $(WARNINGS)
++CFLAGS=@CFLAGS@ @INCLUDES@ -DTRIO_MINIMAL $(WARNINGS)
+ YACC=@YACC@
+ NETLIBS=@LIBS@
+-LDFLAGS=@LDFLAGS@ -Lpcre/.libs
++LDFLAGS=@LDFLAGS@
+ MISC_LIBS= -lm -lpcre
+ OPT_LIBS=@EXTRA_LIBS@
+@@ -58,7 +58,7 @@ MAILOBJS=    mail.o ../libcgi/libcgi.a
+ .c.o:
+       $(CC) -c $(CFLAGS) $<
+-all:    pcre/.libs/libpcre.a @FNV_DEP@ hypermail$(SUFFIX) mail$(SUFFIX) lang$(SUFFIX)
++all:    @FNV_DEP@ hypermail$(SUFFIX) mail$(SUFFIX) lang$(SUFFIX)
+ pcre/.libs/libpcre.a:
+       @cd pcre; $(MAKE) CC="$(CC)" CFLAGS="$(CFLAGS)" ; rm -f .libs/lib*.so*
+@@ -87,7 +87,7 @@ getdate.c: getdate.y getdate.h
+ install: all
+       @if [ ! -d $(bindir) ]; then mkdir -p $(bindir); fi
+-      $(INSTALL_PROG) -s -c -m 0755 hypermail$(SUFFIX) $(bindir)
++      $(INSTALL_PROG) -c -m 0755 hypermail$(SUFFIX) $(bindir)
+ mail.install:
+       @if [ ! -d $(cgidir) ]; then mkdir -p $(cgidir); fi
+@@ -124,17 +124,14 @@ clean:
+       rm -f *.o .pure *qx *qv *.ln core
+       rm -f .inslog tca.map lint.out splint.out
+       rm -f getdate.c
+-      @cd pcre; $(MAKE) clean
+       @(if test "$(FNV_DEP)" != "" ; then cd fnv; $(MAKE) clean; fi)
+       @cd ../libcgi; $(MAKE) clean
+ clobber: clean
+-      @cd pcre; rm -f *.lock
+       @(if test "$(FNV_DEP)" != "" ; then cd fnv; $(MAKE) clobber; fi)
+       @cd ../libcgi; $(MAKE) clobber
+ distclean: clobber
+-      @cd pcre; $(MAKE) distclean
+       @(if test "$(FNV_DEP)" != "" ; then cd fnv; $(MAKE) distclean; fi)
+       @cd ../libcgi; $(MAKE) distclean
+diff --git a/src/trio.c b/src/trio.c
+index e9443ae..4b52aa7 100644
+--- a/src/trio.c
++++ b/src/trio.c
+@@ -605,6 +605,13 @@ enum {
+ # define QUALIFIER_ROUNDING_UPPER 'R'
+ #endif
++#ifdef __alpha__
++# define arglist_not_NULL      (arglist.__base != NULL)
++ static va_list NULL_arglist = {NULL, 0};
++#else
++# define arglist_not_NULL      (arglist != NULL)
++# define NULL_arglist          NULL
++#endif
+ /*************************************************************************
+  *
diff --git a/debian/patches/series b/debian/patches/series
new file mode 100644 (file)
index 0000000..08df0e8
--- /dev/null
@@ -0,0 +1 @@
+0001-Import-Debian-patches-from-2.2.0.patch